ai engine vulnerabilities and fixes
Recent CVEs affecting ai engine, with upgrade or downgrade steps. 3 tracked.
Also searched as: aiengine.
ai engine has 3 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 3. Most recent: 2025-07-08. Highest priority: CVE-2024-10499 (score 43/100).
- CVE-2025-5570 MEDIUM 5.4 UPGRADE The AI Engine plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the mwai_chatbot shortcode
- CVE-2024-6723 MEDIUM 4.7 UPGRADE The AI Engine WordPress plugin before 2.4.8 does not properly sanitise and escape a parameter before using it
- CVE-2024-10499 HIGH 7.2 UPGRADE The AI Engine WordPress plugin before 2.6.5 does not sanitize and escape a parameter from one of its RESP API
FAQ
How do I fix ai engine vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is ai engine being exploited right now?
None of the tracked ai engine CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which ai engine CVE should I patch first?
CVE-2024-10499 currently ranks highest (43/100): The AI Engine WordPress plugin before 2.6.5 does not sanitize and escape a parameter from one of its RESP API .