<?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="../assets/feed.xsl"?><rss version="2.0"><channel><title>PatchTheCVE: api gateway</title><link>https://patchthecve.com/</link><description>CVEs with upgrade or downgrade fix steps</description><item><title>CVE-2020-1971: The X.509 GeneralName type is a generic type for representing different types of names</title><link>https://patchthecve.com/cve/CVE-2020-1971.html</link><guid>https://patchthecve.com/cve/CVE-2020-1971.html</guid><pubDate>Wed, 17 Jun 2026 03:02:44 +0000</pubDate><description>MEDIUM 5.9: The X.509 GeneralName type is a generic type for representing different types of names. One of those name types is known as EDIPartyName. OpenSSL provides a function GENERAL_NAME_cmp which compares different instances of a GENERAL_NAME to see if they are equal or not. This function behaves incorrect</description></item><item><title>CVE-2019-17566: Apache Batik is vulnerable to server-side request forgery, caused by improper input validation by the &quot;xlink:h</title><link>https://patchthecve.com/cve/CVE-2019-17566.html</link><guid>https://patchthecve.com/cve/CVE-2019-17566.html</guid><pubDate>Wed, 17 Jun 2026 02:24:10 +0000</pubDate><description>HIGH 7.5: Apache Batik is vulnerable to server-side request forgery, caused by improper input validation by the &quot;xlink:href&quot; attributes. By using a specially-crafted argument, an attacker could exploit this vulnerability to cause the underlying server to make arbitrary GET requests.</description></item><item><title>CVE-2020-11979: As mitigation for CVE-2020-1945 Apache Ant 1.10.8 changed the permissions of temporary files it created so tha</title><link>https://patchthecve.com/cve/CVE-2020-11979.html</link><guid>https://patchthecve.com/cve/CVE-2020-11979.html</guid><pubDate>Thu, 08 Oct 2026 22:16:55 +0000</pubDate><description>HIGH 7.5: As mitigation for CVE-2020-1945 Apache Ant 1.10.8 changed the permissions of temporary files it created so that only the current user was allowed to access them. Unfortunately the fixcrlf task deleted the temporary file and created a new one without said protection, effectively nullifying the effort</description></item><item><title>CVE-2019-15631: Remote Code Execution vulnerability in MuleSoft Mule CE/EE 3.x and API Gateway 2.x released before October 31,</title><link>https://patchthecve.com/cve/CVE-2019-15631.html</link><guid>https://patchthecve.com/cve/CVE-2019-15631.html</guid><pubDate>Wed, 17 Jun 2026 02:20:47 +0000</pubDate><description>CRITICAL 9.8: Remote Code Execution vulnerability in MuleSoft Mule CE/EE 3.x and API Gateway 2.x released before October 31, 2019 allows remote attackers to execute arbitrary code.</description></item><item><title>CVE-2019-15630: Directory Traversal in APIkit, HTTP connector, and OAuth2 Provider components in MuleSoft Mule Runtime 3.2.0 a</title><link>https://patchthecve.com/cve/CVE-2019-15630.html</link><guid>https://patchthecve.com/cve/CVE-2019-15630.html</guid><pubDate>Wed, 17 Jun 2026 02:20:46 +0000</pubDate><description>HIGH 7.5: Directory Traversal in APIkit, HTTP connector, and OAuth2 Provider components in MuleSoft Mule Runtime 3.2.0 and higher released before August 1 2019, MuleSoft Mule Runtime 4.1.0 and higher released before August 1 2019, and all versions of MuleSoft API Gateway released before August 1 2019 allow re</description></item><item><title>CVE-2018-5407: Simultaneous Multi-threading (SMT) in processors can enable local users to exploit software vulnerable to timi</title><link>https://patchthecve.com/cve/CVE-2018-5407.html</link><guid>https://patchthecve.com/cve/CVE-2018-5407.html</guid><pubDate>Thu, 08 Oct 2026 22:16:46 +0000</pubDate><description>MEDIUM 4.7: Simultaneous Multi-threading (SMT) in processors can enable local users to exploit software vulnerable to timing attacks via a side-channel timing attack on &#x27;port contention&#x27;.</description></item><item><title>CVE-2018-1000613: Legion of the Bouncy Castle Legion of the Bouncy Castle Java Cryptography APIs 1.58 up to but not including 1.</title><link>https://patchthecve.com/cve/CVE-2018-1000613.html</link><guid>https://patchthecve.com/cve/CVE-2018-1000613.html</guid><pubDate>Wed, 17 Jun 2026 01:32:56 +0000</pubDate><description>CRITICAL 9.8: Legion of the Bouncy Castle Legion of the Bouncy Castle Java Cryptography APIs 1.58 up to but not including 1.60 contains a CWE-470: Use of Externally-Controlled Input to Select Classes or Code (&#x27;Unsafe Reflection&#x27;) vulnerability in XMSS/XMSS^MT private key deserialization that can result in Deseria</description></item><item><title>CVE-2018-1000180: Bouncy Castle BC 1.54 - 1.59, BC-FJA 1.0.0, BC-FJA 1.0.1 and earlier have a flaw in the Low-level interface to</title><link>https://patchthecve.com/cve/CVE-2018-1000180.html</link><guid>https://patchthecve.com/cve/CVE-2018-1000180.html</guid><pubDate>Wed, 17 Jun 2026 01:32:37 +0000</pubDate><description>HIGH 7.5: Bouncy Castle BC 1.54 - 1.59, BC-FJA 1.0.0, BC-FJA 1.0.1 and earlier have a flaw in the Low-level interface to RSA key pair generator, specifically RSA Key Pairs generated in low-level API with added certainty may have less M-R tests than expected. This appears to be fixed in versions BC 1.60 beta 4</description></item><item><title>CVE-2017-3601: Vulnerability in the Oracle API Gateway component of Oracle Fusion Middleware (subcomponent: Oracle API Gatewa</title><link>https://patchthecve.com/cve/CVE-2017-3601.html</link><guid>https://patchthecve.com/cve/CVE-2017-3601.html</guid><pubDate>Wed, 17 Jun 2026 01:18:40 +0000</pubDate><description>HIGH 8.1: Vulnerability in the Oracle API Gateway component of Oracle Fusion Middleware (subcomponent: Oracle API Gateway). The supported version that is affected is 11.1.2.4.0. Easily &quot;exploitable&quot; vulnerability allows unauthenticated attacker with network access via HTTP to compromise Oracle API Gateway. Su</description></item><item><title>CVE-2016-3118: CRLF injection vulnerability in CA API Gateway (formerly Layer7 API Gateway) 7.1 before 7.1.04, 8.0 through 8.</title><link>https://patchthecve.com/cve/CVE-2016-3118.html</link><guid>https://patchthecve.com/cve/CVE-2016-3118.html</guid><pubDate>Wed, 17 Jun 2026 00:45:00 +0000</pubDate><description>MEDIUM 6.5: CRLF injection vulnerability in CA API Gateway (formerly Layer7 API Gateway) 7.1 before 7.1.04, 8.0 through 8.3 before 8.3.01, and 8.4 before 8.4.01 allows remote attackers to have an unspecified impact via unknown vectors.</description></item><item><title>CVE-2015-3195: The ASN1_TFLG_COMBINE implementation in crypto/asn1/tasn_dec.c in OpenSSL before 0.9.8zh, 1.0.0 before 1.0.0t,</title><link>https://patchthecve.com/cve/CVE-2015-3195.html</link><guid>https://patchthecve.com/cve/CVE-2015-3195.html</guid><pubDate>Wed, 17 Jun 2026 00:25:30 +0000</pubDate><description>MEDIUM 5.3: The ASN1_TFLG_COMBINE implementation in crypto/asn1/tasn_dec.c in OpenSSL before 0.9.8zh, 1.0.0 before 1.0.0t, 1.0.1 before 1.0.1q, and 1.0.2 before 1.0.2e mishandles errors caused by malformed X509_ATTRIBUTE data, which allows remote attackers to obtain sensitive information from process memory by </description></item></channel></rss>