arangodb vulnerabilities and fixes
Recent CVEs affecting arangodb, with upgrade or downgrade steps. 3 tracked.
arangodb has 3 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 3. Most recent: 2022-02-09. Highest priority: CVE-2021-25940 (score 45/100).
- CVE-2021-25940 HIGH 8.8 UPGRADE In ArangoDB, versions v3.7.6 through v3.8.3 are vulnerable to Insufficient Session Expiration
- CVE-2021-25939 LOW 2.7 UPGRADE In ArangoDB, versions v3.7.0 through v3.9.0-alpha.1 have a feature which allows downloading a Foxx service fro
- CVE-2021-25938 MEDIUM 6.1 UPGRADE In ArangoDB, versions v2.2.6.2 through v3.7.10 are vulnerable to Cross-Site Scripting (XSS), since there is no
FAQ
How do I fix arangodb vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is arangodb being exploited right now?
None of the tracked arangodb CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which arangodb CVE should I patch first?
CVE-2021-25940 currently ranks highest (45/100): In ArangoDB, versions v3.7.6 through v3.8.3 are vulnerable to Insufficient Session Expiration.