blogengine.net vulnerabilities and fixes
Recent CVEs affecting blogengine.net, with upgrade or downgrade steps. 10 tracked.
Also searched as: blogengine net, blogenginenet.
blogengine.net has 10 tracked vulnerabilities, 3 critical. A fixed release or vendor patch exists for 2. Most recent: 2023-06-26. Highest priority: CVE-2023-33404 (score 72/100).
- CVE-2023-33405 MEDIUM 6.1 UPGRADE Blogengine.net 3.3.8.0 and earlier is vulnerable to Open Redirect.
- CVE-2023-33404 CRITICAL 9.8 UPGRADE An Unrestricted Upload vulnerability, due to insufficient validation on UploadControlled.cs file, in BlogEngin
- CVE-2023-22858 MEDIUM 5.3 DOWNGRADE An Improper Access Control vulnerability in BlogEngine.NET 3.3.8.0, allows unauthenticated visitors to access
- CVE-2023-22857 HIGH 8.5 DOWNGRADE A stored Cross-site Scripting (XSS) vulnerability in BlogEngine.NET 3.3.8.0, allows injection of arbitrary Jav
- CVE-2023-22856 HIGH 8.5 DOWNGRADE A stored Cross-site Scripting (XSS) vulnerability in BlogEngine.NET 3.3.8.0, allows injection of arbitrary Jav
- CVE-2022-41418 HIGH 7.2 DOWNGRADE An issue in the component BlogEngine/BlogEngine.NET/AppCode/Api/UploadController.cs of BlogEngine.NET v3.3.8.0
- CVE-2022-41417 CRITICAL 9.8 DOWNGRADE BlogEngine.NET v3.3.8.0 allows an attacker to create any folder with "files" prefix under ~/App_Data/.
- CVE-2022-36600 MEDIUM 4.8 DOWNGRADE BlogEngine v3.3.8.0 was discovered to contain a cross-site scripting (XSS) vulnerability in the component /blo
- CVE-2022-28921 MEDIUM 6.5 DOWNGRADE A Cross-Site Request Forgery (CSRF) vulnerability discovered in BlogEngine.Net v3.3.8.0 allows unauthenticated
- CVE-2022-25591 CRITICAL 9.1 DOWNGRADE BlogEngine.NET v3.3.8.0 was discovered to contain an arbitrary file deletion vulnerability which allows attack
FAQ
How do I fix blogengine.net vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is blogengine.net being exploited right now?
None of the tracked blogengine.net CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which blogengine.net CVE should I patch first?
CVE-2023-33404 currently ranks highest (72/100): An Unrestricted Upload vulnerability, due to insufficient validation on UploadControlled.cs file, in BlogEngin.