dragonfly vulnerabilities and fixes
Recent CVEs affecting dragonfly, with upgrade or downgrade steps. 4 tracked.
dragonfly has 4 tracked vulnerabilities, 2 critical. A fixed release or vendor patch exists for 4. Most recent: 2026-01-22. Highest priority: CVE-2023-27584 (score 77/100).
- CVE-2026-24124 CRITICAL 9.8 UPGRADE Dragonfly is an open source P2P-based file distribution and image acceleration system
- CVE-2025-26269 LOW 3.3 UPGRADE DragonflyDB Dragonfly through 1.28.2 (fixed in 1.29.0) allows authenticated users to cause a denial of service
- CVE-2025-26268 LOW 3.3 UPGRADE DragonflyDB Dragonfly before 1.27.0 allows authenticated users to cause a denial of service (daemon crash) via
- CVE-2023-27584 CRITICAL 9.8 UPGRADE Dragonfly is an open source P2P-based file distribution and image acceleration system
FAQ
How do I fix dragonfly vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is dragonfly being exploited right now?
None of the tracked dragonfly CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which dragonfly CVE should I patch first?
CVE-2023-27584 currently ranks highest (77/100): Dragonfly is an open source P2P-based file distribution and image acceleration system.