e107 vulnerabilities and fixes
Recent CVEs affecting e107, with upgrade or downgrade steps. 7 tracked.
e107 has 7 tracked vulnerabilities, 1 critical. A fixed release or vendor patch exists for 3. Most recent: 2026-01-13. Highest priority: CVE-2022-50905 (score 58/100).
- CVE-2025-11941 MEDIUM 5.4 UPGRADE A vulnerability was detected in e107 CMS up to 2.3.3
- CVE-2025-61505 MEDIUM 6.5 UPGRADE e107 CMS thru 2.3.3 are vulnerable to insecure deserialization in the `install.php` script
- CVE-2022-50939 HIGH 7.2 DOWNGRADE e107 CMS version 3.2.1 contains a critical file upload vulnerability that allows authenticated administrators
- CVE-2022-50916 HIGH 7.2 DOWNGRADE e107 CMS version 3.2.1 contains a file upload vulnerability that allows authenticated administrators to overri
- CVE-2022-50907 HIGH 7.2 DOWNGRADE e107 CMS version 3.2.1 contains a file upload vulnerability that allows authenticated administrative users to
- CVE-2022-50906 MEDIUM 4.8 DOWNGRADE e107 CMS 3.2.1 contains an upload restriction bypass vulnerability that allows authenticated administrators to
- CVE-2022-50905 CRITICAL 9.8 DOWNGRADE e107 CMS version 3.2.1 contains multiple vulnerabilities that allow cross-site scripting (XSS) attacks
FAQ
How do I fix e107 vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is e107 being exploited right now?
None of the tracked e107 CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which e107 CVE should I patch first?
CVE-2022-50905 currently ranks highest (58/100): e107 CMS version 3.2.1 contains multiple vulnerabilities that allow cross-site scripting (XSS) attacks.