elm vulnerabilities and fixes
Recent CVEs affecting elm, with upgrade or downgrade steps. 4 tracked.
elm has 4 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 2. Most recent: 2004-02-17. Highest priority: CVE-2001-1174 (score 49/100).
- CVE-2003-1323 MEDIUM 6.8 DOWNGRADE Elm ME+ 2.4 before PL109S, when installed setgid mail and the operating system lacks POSIX saved ID support, a
- CVE-2003-0966 HIGH 7.5 UPGRADE Buffer overflow in the frm command in elm 2.5.6 and earlier, and possibly later versions, allows remote attack
- CVE-2001-1174 HIGH 7.5 UPGRADE Buffer overflow in Elm 2.5.5 and earlier allows remote attackers to execute arbitrary code via a long Message-
- CVE-1999-1334 HIGH 7.5 DOWNGRADE Multiple buffer overflows in filter command in Elm 2.4 allows attackers to execute arbitrary commands via (1)
FAQ
How do I fix elm vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is elm being exploited right now?
None of the tracked elm CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which elm CVE should I patch first?
CVE-2001-1174 currently ranks highest (49/100): Buffer overflow in Elm 2.5.5 and earlier allows remote attackers to execute arbitrary code via a long Message-.