eta vulnerabilities and fixes
Recent CVEs affecting eta, with upgrade or downgrade steps. 2 tracked.
eta has 2 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 2. Most recent: 2023-02-01. Highest priority: CVE-2022-25967 (score 54/100).
- CVE-2023-23630 HIGH 8.6 UPGRADE Eta is an embedded JS templating engine that works inside Node, Deno, and the browser
- CVE-2022-25967 HIGH 8.1 UPGRADE Versions of the package eta before 2.0.0 are vulnerable to Remote Code Execution (RCE) by overwriting template
FAQ
How do I fix eta vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is eta being exploited right now?
None of the tracked eta CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which eta CVE should I patch first?
CVE-2022-25967 currently ranks highest (54/100): Versions of the package eta before 2.0.0 are vulnerable to Remote Code Execution (RCE) by overwriting template.