etherpad vulnerabilities and fixes
Recent CVEs affecting etherpad, with upgrade or downgrade steps. 7 tracked.
etherpad has 7 tracked vulnerabilities, 1 critical. A fixed release or vendor patch exists for 5. Most recent: 2021-12-09. Highest priority: CVE-2021-43802 (score 55/100).
- CVE-2021-43802 CRITICAL 9.9 UPGRADE Etherpad is a real-time collaborative editor
- CVE-2021-34817 MEDIUM 6.1 DOWNGRADE A Cross-Site Scripting (XSS) issue in the chat component of Etherpad 1.8.13 allows remote attackers to inject
- CVE-2021-34816 HIGH 7.2 DOWNGRADE An Argument Injection issue in the plugin management of Etherpad 1.8.13 allows privileged users to execute arb
- CVE-2020-22785 HIGH 7.5 UPGRADE Etherpad < 1.8.3 is affected by a missing lock check which could cause a denial of service
- CVE-2020-22783 MEDIUM 6.5 UPGRADE Etherpad <1.8.3 stored passwords used by users insecurely in the database and in log files
- CVE-2020-22782 HIGH 7.5 UPGRADE Etherpad < 1.8.3 is affected by a denial of service in the import functionality
- CVE-2020-22781 HIGH 7.5 UPGRADE In Etherpad < 1.8.3, a specially crafted URI would raise an unhandled exception in the cache mechanism and cau
FAQ
How do I fix etherpad vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is etherpad being exploited right now?
None of the tracked etherpad CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which etherpad CVE should I patch first?
CVE-2021-43802 currently ranks highest (55/100): Etherpad is a real-time collaborative editor.