eve x1 server firmware vulnerabilities and fixes
Recent CVEs affecting eve x1 server firmware, with upgrade or downgrade steps. 16 tracked.
Also searched as: evex1serverfirmware.
eve x1 server firmware has 16 tracked vulnerabilities, 7 critical. A fixed release or vendor patch exists for 15. Most recent: 2025-11-25. Highest priority: CVE-2025-34513 (score 71/100).
- CVE-2025-34513 CRITICAL 9.8 UPGRADE Ilevia EVE X1 Server firmware versions ≤ 4.7.18.0.eden contain an OS command injection vulnerability in mbus_b
- CVE-2025-34515 CRITICAL 9.8 UPGRADE Ilevia EVE X1 Server firmware versions ≤ 4.7.18.0.eden contain an execution with unnecessary privileges vulner
- CVE-2025-34514 HIGH 8.8 UPGRADE Ilevia EVE X1 Server firmware versions ≤ 4.7.18.0.eden contain authenticated OS command injection vulnerabilit
- CVE-2025-34516 CRITICAL 9.8 UPGRADE Ilevia EVE X1 Server firmware versions ≤ 4.7.18.0.eden contain a use of default credentials vulnerability that
- CVE-2025-34517 HIGH 7.5 UPGRADE Ilevia EVE X1 Server firmware versions ≤ 4.7.18.0.eden contain an absolute path traversal vulnerability in get
- CVE-2025-34518 HIGH 7.5 UPGRADE Ilevia EVE X1 Server firmware versions ≤ 4.7.18.0.eden contain a relative path traversal vulnerability in get_
- CVE-2025-34519 HIGH 7.5 UPGRADE Ilevia EVE X1 Server firmware versions ≤ 4.7.18.0.eden contain an insecure hashing algorithm vulnerability. Th
- CVE-2025-34512 MEDIUM 6.1 UPGRADE Ilevia EVE X1 Server firmware versions ≤ 4.7.18.0.eden contain a reflected cross-site scripting (XSS) vulnerab
- CVE-2025-60739 CRITICAL 9.6 MITIGATE Cross Site Request Forgery (CSRF) vulnerability in Ilevia EVE X1 Server Firmware Version v4.7.18.0.eden and be
- CVE-2025-60738 CRITICAL 9.8 MITIGATE An issue in Ilevia EVE X1 Server Firmware Version v4.7.18.0.eden and before Logic Version v6.00 - 2025_07_21 a
- CVE-2025-60737 MEDIUM 6.1 UPGRADE Cross Site Scripting vulnerability in Ilevia EVE X1 Server Firmware Version<= 4.7.18.0.eden:Logic Version<=6.0
- CVE-2025-34187 HIGH 8.8 UPGRADE Ilevia EVE X1/X5 Server version ≤ 4.7.18.0.eden contains a misconfiguration in the sudoers file that allows pa
- CVE-2025-34186 CRITICAL 9.8 UPGRADE Ilevia EVE X1/X5 Server version ≤ 4.7.18.0.eden contains a vulnerability in its authentication mechanism
- CVE-2025-34185 HIGH 7.5 UPGRADE Ilevia EVE X1 Server version ≤ 4.7.18.0.eden contains a pre-authentication file disclosure vulnerability via t
- CVE-2025-34184 CRITICAL 9.8 UPGRADE Ilevia EVE X1 Server version ≤ 4.7.18.0.eden contains an unauthenticated OS command injection vulnerability in
- CVE-2025-34183 HIGH 7.5 UPGRADE Ilevia EVE X1 Server version ≤ 4.7.18.0.eden contains a vulnerability in its server-side logging mechanism tha
FAQ
How do I fix eve x1 server firmware vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is eve x1 server firmware being exploited right now?
None of the tracked eve x1 server firmware CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which eve x1 server firmware CVE should I patch first?
CVE-2025-34513 currently ranks highest (71/100): Ilevia EVE X1 Server firmware versions ≤ 4.7.18.0.eden contain an OS command injection vulnerability in mbus_b.