fcgi vulnerabilities and fixes
Recent CVEs affecting fcgi, with upgrade or downgrade steps. 1 tracked.
fcgi has 1 tracked vulnerability, 0 critical. A fixed release or vendor patch exists for 1. Most recent: 2025-05-16. Highest priority: CVE-2025-40907 (score 42/100).
- CVE-2025-40907 MEDIUM 5.3 UPGRADE FCGI versions 0.44 through 0.82, for Perl, include a vulnerable version of the FastCGI fcgi2 (aka fcgi) librar
FAQ
How do I fix fcgi vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is fcgi being exploited right now?
None of the tracked fcgi CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which fcgi CVE should I patch first?
CVE-2025-40907 currently ranks highest (42/100): FCGI versions 0.44 through 0.82, for Perl, include a vulnerable version of the FastCGI fcgi2 (aka fcgi) librar.