<?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="../assets/feed.xsl"?><rss version="2.0"><channel><title>PatchTheCVE: framework</title><link>https://patchthecve.com/</link><description>CVEs with upgrade or downgrade fix steps</description><item><title>CVE-2025-30148: Silverstripe Framework is a PHP framework which powers the Silverstripe CMS</title><link>https://patchthecve.com/cve/CVE-2025-30148.html</link><guid>https://patchthecve.com/cve/CVE-2025-30148.html</guid><pubDate>Wed, 17 Jun 2026 09:08:15 +0000</pubDate><description>MEDIUM 5.4: Silverstripe Framework is a PHP framework which powers the Silverstripe CMS. Prior to 5.3.23, bad actor with access to edit content in the CMS could send a specifically crafted encoded payload to the server, which could be used to inject a JavaScript payload on the front end of the site. The payload</description></item><item><title>CVE-2024-13919: The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting du</title><link>https://patchthecve.com/cve/CVE-2024-13919.html</link><guid>https://patchthecve.com/cve/CVE-2024-13919.html</guid><pubDate>Wed, 17 Jun 2026 07:02:59 +0000</pubDate><description>HIGH 8.0: The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting due to an improper encoding of route parameters in the debug-mode error page.</description></item><item><title>CVE-2024-13918: The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting du</title><link>https://patchthecve.com/cve/CVE-2024-13918.html</link><guid>https://patchthecve.com/cve/CVE-2024-13918.html</guid><pubDate>Wed, 17 Jun 2026 07:02:59 +0000</pubDate><description>HIGH 8.0: The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting due to an improper encoding of request parameters in the debug-mode error page.</description></item><item><title>CVE-2025-27515: Laravel is a web application framework</title><link>https://patchthecve.com/cve/CVE-2025-27515.html</link><guid>https://patchthecve.com/cve/CVE-2025-27515.html</guid><pubDate>Wed, 17 Jun 2026 09:03:44 +0000</pubDate><description>CRITICAL 9.8: Laravel is a web application framework. When using wildcard validation to validate a given file or image field (`files.*`), a user-crafted malicious request could potentially bypass the validation rules. This vulnerability is fixed in 11.44.1 and 12.1.1.</description></item><item><title>CVE-2024-53277: Silverstripe Framework is a PHP framework which powers the Silverstripe CMS</title><link>https://patchthecve.com/cve/CVE-2024-53277.html</link><guid>https://patchthecve.com/cve/CVE-2024-53277.html</guid><pubDate>Wed, 17 Jun 2026 08:08:44 +0000</pubDate><description>MEDIUM 5.4: Silverstripe Framework is a PHP framework which powers the Silverstripe CMS. In some cases, form messages can contain HTML markup. This is an intentional feature, allowing links and other relevant HTML markup for the given message. Some form messages include content that the user can provide. There </description></item><item><title>CVE-2024-52301: Laravel is a web application framework</title><link>https://patchthecve.com/cve/CVE-2024-52301.html</link><guid>https://patchthecve.com/cve/CVE-2024-52301.html</guid><pubDate>Wed, 17 Jun 2026 08:06:58 +0000</pubDate><description>HIGH 7.5: Laravel is a web application framework. When the register_argc_argv php directive is set to on , and users call any URL with a special crafted query string, they are able to change the environment used by the framework when handling the request. The vulnerability fixed in 6.20.45, 7.30.7, 8.83.28, 9</description></item><item><title>CVE-2024-9443: The Basticom Framework plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads </title><link>https://patchthecve.com/cve/CVE-2024-9443.html</link><guid>https://patchthecve.com/cve/CVE-2024-9443.html</guid><pubDate>Wed, 17 Jun 2026 08:24:34 +0000</pubDate><description>MEDIUM 6.4: The Basticom Framework plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.5.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above</description></item><item><title>CVE-2024-32981: Silverstripe framework is the PHP framework forming the base for the Silverstripe CMS</title><link>https://patchthecve.com/cve/CVE-2024-32981.html</link><guid>https://patchthecve.com/cve/CVE-2024-32981.html</guid><pubDate>Wed, 17 Jun 2026 07:30:48 +0000</pubDate><description>MEDIUM 5.4: Silverstripe framework is the PHP framework forming the base for the Silverstripe CMS. In affected versions a bad actor with access to edit content in the CMS could add send a specifically crafted encoded payload to the server, which could be used to inject a JavaScript payload on the front end of t</description></item></channel></rss>