glance vulnerabilities and fixes
Recent CVEs affecting glance, with upgrade or downgrade steps. 5 tracked.
glance has 5 tracked vulnerabilities, 1 critical. A fixed release or vendor patch exists for 4. Most recent: 2024-07-05. Highest priority: CVE-2022-31546 (score 60/100).
- CVE-2024-32498 MEDIUM 6.5 UPGRADE UPGRADE An issue was discovered in OpenStack Cinder through 24.0.0, Glance before 28.0.2, and Nova before 29.0.3
- CVE-2022-4134 LOW 2.8 MITIGATE DOWNGRADE A flaw was found in openstack-glance
- CVE-2022-47951 MEDIUM 5.7 UPGRADE UPGRADE An issue was discovered in OpenStack Cinder before 19.1.2, 20.x before 20.0.2, and 21.0.0; Glance before 23.0.
- CVE-2022-31546 CRITICAL 9.3 UPGRADE The nlpweb/glance repository through 2014-06-27 on GitHub allows absolute path traversal because the Flask sen
- CVE-2022-25937 MEDIUM 6.5 UPGRADE Versions of the package glance before 3.0.9 are vulnerable to Directory Traversal that allows users to read fi
FAQ
How do I fix glance vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is glance being exploited right now?
None of the tracked glance CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which glance CVE should I patch first?
CVE-2022-31546 currently ranks highest (60/100): The nlpweb/glance repository through 2014-06-27 on GitHub allows absolute path traversal because the Flask sen.