gnuboard vulnerabilities and fixes
Recent CVEs affecting gnuboard, with upgrade or downgrade steps. 8 tracked.
gnuboard has 8 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 3. Most recent: 2025-10-23. Highest priority: CVE-2024-41475 (score 41/100).
- CVE-2025-7786 LOW 3.5 UPGRADE A vulnerability, which was classified as problematic, has been found in Gnuboard g6 up to 6.0.10
- CVE-2025-61464 MEDIUM 6.5 UPGRADE gnuboard gnuboard4 v4.36.04 and before is vulnerable to Second-order SQL Injection via the search_table in bbs
- CVE-2025-60859 MEDIUM 6.1 DOWNGRADE Cross Site Scripting (XSS) vulnerability in Gnuboard 5.6.15 allows authenticated attackers to execute arbitrar
- CVE-2024-41475 HIGH 8.8 DOWNGRADE Gnuboard g6 6.0.7 is vulnerable to Session hijacking due to a CORS misconfiguration.
- CVE-2024-39097 MEDIUM 6.1 UPGRADE There is an Open Redirect vulnerability in Gnuboard v6.0.4 and below via the `url` parameter in login path.
- CVE-2024-37658 MEDIUM 6.1 DOWNGRADE An open redirect vulnerability in gnuboard5 v.5.5.16 allows a remote attacker to obtain sensitive information
- CVE-2024-37657 MEDIUM 6.1 DOWNGRADE An open redirect vulnerability in gnuboard5 v.5.5.16 allows a remote attacker to obtain sensitive information
- CVE-2024-37656 MEDIUM 6.1 DOWNGRADE An open redirect vulnerability in gnuboard5 v.5.5.16 allows a remote attacker to obtain sensitive information
FAQ
How do I fix gnuboard vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is gnuboard being exploited right now?
None of the tracked gnuboard CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which gnuboard CVE should I patch first?
CVE-2024-41475 currently ranks highest (41/100): Gnuboard g6 6.0.7 is vulnerable to Session hijacking due to a CORS misconfiguration..