<?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="../assets/feed.xsl"?><rss version="2.0"><channel><title>PatchTheCVE: grails</title><link>https://patchthecve.com/</link><description>CVEs with upgrade or downgrade fix steps</description><item><title>CVE-2023-46131: Grails is a framework used to build web applications with the Groovy programming language</title><link>https://patchthecve.com/cve/CVE-2023-46131.html</link><guid>https://patchthecve.com/cve/CVE-2023-46131.html</guid><pubDate>Wed, 17 Jun 2026 06:30:13 +0000</pubDate><description>MEDIUM 6.5: Grails is a framework used to build web applications with the Groovy programming language. A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable. This issue has been patched in version 3.3.17, 4.1.3, 5.3</description></item><item><title>CVE-2022-35912: In grails-databinding in Grails before 3.3.15, 4.x before 4.1.1, 5.x before 5.1.9, and 5.2.x before 5.2.1 (at </title><link>https://patchthecve.com/cve/CVE-2022-35912.html</link><guid>https://patchthecve.com/cve/CVE-2022-35912.html</guid><pubDate>Wed, 17 Jun 2026 04:52:30 +0000</pubDate><description>CRITICAL 9.8: In grails-databinding in Grails before 3.3.15, 4.x before 4.1.1, 5.x before 5.1.9, and 5.2.x before 5.2.1 (at least when certain Java 8 configurations are used), data binding allows a remote attacker to execute code by gaining access to the class loader.</description></item><item><title>CVE-2019-12728: Grails before 3.3.10 used cleartext HTTP to resolve the SDKMan notification service</title><link>https://patchthecve.com/cve/CVE-2019-12728.html</link><guid>https://patchthecve.com/cve/CVE-2019-12728.html</guid><pubDate>Wed, 17 Jun 2026 02:15:19 +0000</pubDate><description>HIGH 8.1: Grails before 3.3.10 used cleartext HTTP to resolve the SDKMan notification service. NOTE: users&#x27; apps were not resolving dependencies over cleartext HTTP.</description></item><item><title>CVE-2016-6521: Cross-site request forgery (CSRF) vulnerability in Grails console (aka Grails Debug Console and Grails Web Con</title><link>https://patchthecve.com/cve/CVE-2016-6521.html</link><guid>https://patchthecve.com/cve/CVE-2016-6521.html</guid><pubDate>Wed, 17 Jun 2026 00:51:19 +0000</pubDate><description>HIGH 8.8: Cross-site request forgery (CSRF) vulnerability in Grails console (aka Grails Debug Console and Grails Web Console) 2.0.7, 1.5.10, and earlier allows remote attackers to hijack the authentication of users for requests that execute arbitrary Groovy code via unspecified vectors.</description></item><item><title>CVE-2014-2858: Directory traversal vulnerability in the Resources plugin 1.0.0 before 1.2.6 for Pivotal Grails 2.0.0 through </title><link>https://patchthecve.com/cve/CVE-2014-2858.html</link><guid>https://patchthecve.com/cve/CVE-2014-2858.html</guid><pubDate>Wed, 17 Jun 2026 00:07:16 +0000</pubDate><description>MEDIUM 5.0: Directory traversal vulnerability in the Resources plugin 1.0.0 before 1.2.6 for Pivotal Grails 2.0.0 through 2.3.6 allows remote attackers to obtain sensitive information via unspecified vectors related to a &quot;configured block.&quot; NOTE: this issue was SPLIT from CVE-2014-0053 per ADT2 due to different</description></item><item><title>CVE-2014-2857: The default configuration of the Resources plugin 1.0.0 before 1.2.6 for Pivotal Grails 2.0.0 through 2.3.6 do</title><link>https://patchthecve.com/cve/CVE-2014-2857.html</link><guid>https://patchthecve.com/cve/CVE-2014-2857.html</guid><pubDate>Wed, 17 Jun 2026 00:07:16 +0000</pubDate><description>MEDIUM 5.0: The default configuration of the Resources plugin 1.0.0 before 1.2.6 for Pivotal Grails 2.0.0 through 2.3.6 does not properly restrict access to files in the META-INF directory, which allows remote attackers to obtain sensitive information via a direct request.  NOTE: this issue was SPLIT from CVE-2</description></item><item><title>CVE-2014-0053: The default configuration of the Resources plugin 1.0.0 before 1.2.6 for Pivotal Grails 2.0.0 before 2.3.6 doe</title><link>https://patchthecve.com/cve/CVE-2014-0053.html</link><guid>https://patchthecve.com/cve/CVE-2014-0053.html</guid><pubDate>Wed, 17 Jun 2026 00:02:10 +0000</pubDate><description>MEDIUM 5.0: The default configuration of the Resources plugin 1.0.0 before 1.2.6 for Pivotal Grails 2.0.0 before 2.3.6 does not properly restrict access to files in the WEB-INF directory, which allows remote attackers to obtain sensitive information via a direct request.  NOTE: this identifier has been SPLIT du</description></item><item><title>CVE-2012-1833: VMware SpringSource Grails before 1.3.8, and 2.x before 2.0.2, does not properly restrict data binding, which </title><link>https://patchthecve.com/cve/CVE-2012-1833.html</link><guid>https://patchthecve.com/cve/CVE-2012-1833.html</guid><pubDate>Tue, 16 Jun 2026 23:40:23 +0000</pubDate><description>MEDIUM 5.0: VMware SpringSource Grails before 1.3.8, and 2.x before 2.0.2, does not properly restrict data binding, which might allow remote attackers to bypass intended access restrictions and modify arbitrary object properties via a crafted request parameter to an application.</description></item></channel></rss>