gxp1628 firmware vulnerabilities and fixes
Recent CVEs affecting gxp1628 firmware, with upgrade or downgrade steps. 2 tracked.
Also searched as: gxp1628firmware.
gxp1628 firmware has 2 tracked vulnerabilities, 1 critical. A fixed release or vendor patch exists for 2. Most recent: 2026-02-18. Highest priority: CVE-2026-2329 (score 72/100).
- CVE-2025-28170 HIGH 7.6 UPGRADE Grandstream Networks GXP1628 <=1.0.4.130 is vulnerable to Incorrect Access Control
- CVE-2026-2329 CRITICAL 9.8 UPGRADE UPGRADE An unauthenticated stack-based buffer overflow vulnerability exists in the HTTP API endpoint /cgi-bin/api.valu
FAQ
How do I fix gxp1628 firmware vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is gxp1628 firmware being exploited right now?
None of the tracked gxp1628 firmware CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which gxp1628 firmware CVE should I patch first?
CVE-2026-2329 currently ranks highest (72/100): An unauthenticated stack-based buffer overflow vulnerability exists in the HTTP API endpoint /cgi-bin/api.valu.