<?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="../assets/feed.xsl"?><rss version="2.0"><channel><title>PatchTheCVE: htmlunit</title><link>https://patchthecve.com/</link><description>CVEs with upgrade or downgrade fix steps</description><item><title>CVE-2023-49093: HtmlUnit is a GUI-less browser for Java programs</title><link>https://patchthecve.com/cve/CVE-2023-49093.html</link><guid>https://patchthecve.com/cve/CVE-2023-49093.html</guid><pubDate>Wed, 17 Jun 2026 06:35:21 +0000</pubDate><description>CRITICAL 9.8: HtmlUnit is a GUI-less browser for Java programs. HtmlUnit is vulnerable to Remote Code Execution (RCE) via XSTL, when browsing the attacker’s webpage. This vulnerability has been patched in version 3.9.0</description></item><item><title>CVE-2023-2798: Those using HtmlUnit to browse untrusted webpages may be vulnerable to Denial of service attacks (DoS)</title><link>https://patchthecve.com/cve/CVE-2023-2798.html</link><guid>https://patchthecve.com/cve/CVE-2023-2798.html</guid><pubDate>Wed, 17 Jun 2026 05:53:27 +0000</pubDate><description>HIGH 7.5: Those using HtmlUnit to browse untrusted webpages may be vulnerable to Denial of service attacks (DoS). If HtmlUnit is running on user supplied web pages, an attacker may supply content that causes HtmlUnit to crash by a stack overflow. This effect may support a denial of service attack.This issue a</description></item><item><title>CVE-2023-26119: Versions of the package net.sourceforge.htmlunit:htmlunit from 0 and before 3.0.0 are vulnerable to Remote Cod</title><link>https://patchthecve.com/cve/CVE-2023-26119.html</link><guid>https://patchthecve.com/cve/CVE-2023-26119.html</guid><pubDate>Thu, 08 Oct 2026 22:17:23 +0000</pubDate><description>CRITICAL 9.8: Versions of the package net.sourceforge.htmlunit:htmlunit from 0 and before 3.0.0 are vulnerable to Remote Code Execution (RCE) via XSTL, when browsing the attacker’s webpage.</description></item><item><title>CVE-2022-29546: HtmlUnit NekoHtml Parser before 2.61.0 suffers from a denial of service vulnerability</title><link>https://patchthecve.com/cve/CVE-2022-29546.html</link><guid>https://patchthecve.com/cve/CVE-2022-29546.html</guid><pubDate>Wed, 17 Jun 2026 04:40:24 +0000</pubDate><description>HIGH 7.5: HtmlUnit NekoHtml Parser before 2.61.0 suffers from a denial of service vulnerability. Crafted input associated with the parsing of Processing Instruction (PI) data leads to heap memory consumption. This is similar to CVE-2022-28366 but affects a much later version of the product.</description></item><item><title>CVE-2022-28366: Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that</title><link>https://patchthecve.com/cve/CVE-2022-28366.html</link><guid>https://patchthecve.com/cve/CVE-2022-28366.html</guid><pubDate>Wed, 17 Jun 2026 04:38:26 +0000</pubDate><description>HIGH 7.5: Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also</description></item><item><title>CVE-2020-5529: HtmlUnit prior to 2.37.0 contains code execution vulnerabilities</title><link>https://patchthecve.com/cve/CVE-2020-5529.html</link><guid>https://patchthecve.com/cve/CVE-2020-5529.html</guid><pubDate>Wed, 17 Jun 2026 03:21:32 +0000</pubDate><description>HIGH 8.1: HtmlUnit prior to 2.37.0 contains code execution vulnerabilities. HtmlUnit initializes Rhino engine improperly, hence a malicious JavScript code can execute arbitrary Java code on the application. Moreover, when embedded in Android application, Android-specific initialization of Rhino engine is done</description></item></channel></rss>