i-doit vulnerabilities and fixes
Recent CVEs affecting i-doit, with upgrade or downgrade steps. 11 tracked.
Also searched as: i doit.
i-doit has 11 tracked vulnerabilities, 3 critical. A fixed release or vendor patch exists for 9. Most recent: 2023-10-21. Highest priority: CVE-2023-37756 (score 63/100).
- CVE-2023-46003 MEDIUM 5.4 UPGRADE I-doit pro 25 and below is vulnerable to Cross Site Scripting (XSS) via index.php.
- CVE-2023-37756 CRITICAL 9.8 UPGRADE I-doit pro 25 and below and I-doit open 25 and below employ weak password requirements for Administrator accou
- CVE-2023-37755 CRITICAL 9.8 UPGRADE i-doit pro 25 and below and I-doit open 25 and below are configured with insecure default administrator creden
- CVE-2023-37739 MEDIUM 6.5 UPGRADE i-doit Pro v25 and below was discovered to be vulnerable to path traversal.
- CVE-2023-34830 MEDIUM 5.4 UPGRADE i-doit Open v24 was discovered to contain a reflected cross-site scripting (XSS) vulnerability via the timeout
- CVE-2021-3151 MEDIUM 5.4 UPGRADE i-doit before 1.16.0 is affected by Stored Cross-Site Scripting (XSS) issues that could allow remote authentic
- CVE-2020-13826 HIGH 8.8 UPGRADE A CSV injection (aka Excel Macro Injection or Formula Injection) issue in i-doit 1.14.2 allows an attacker to
- CVE-2020-13825 MEDIUM 6.1 UPGRADE A cross-site scripting (XSS) vulnerability in i-doit 1.14.2 allows remote attackers to inject arbitrary web sc
- CVE-2019-6965 MEDIUM 6.1 DOWNGRADE An XSS issue was discovered in i-doit Open 1.12 via the src/tools/php/qr/qr.php url parameter.
- CVE-2019-1010248 CRITICAL 9.8 UPGRADE Synetics GmbH I-doit 1.12 and earlier is affected by: SQL Injection
- CVE-2018-20159 HIGH 7.2 DOWNGRADE i-doit open 1.11.2 allows Remote Code Execution because ZIP archives are mishandled
FAQ
How do I fix i-doit vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is i-doit being exploited right now?
None of the tracked i-doit CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which i-doit CVE should I patch first?
CVE-2023-37756 currently ranks highest (63/100): I-doit pro 25 and below and I-doit open 25 and below employ weak password requirements for Administrator accou.