jsrsasign vulnerabilities and fixes
Recent CVEs affecting jsrsasign, with upgrade or downgrade steps. 6 tracked.
jsrsasign has 6 tracked vulnerabilities, 1 critical. A fixed release or vendor patch exists for 6. Most recent: 2026-03-23. Highest priority: CVE-2026-4599 (score 52/100).
- CVE-2026-4602 HIGH 7.5 UPGRADE Versions of the package jsrsasign before 11.1.1 are vulnerable to Incorrect Conversion between Numeric Types d
- CVE-2026-4601 HIGH 8.7 UPGRADE Versions of the package jsrsasign before 11.1.1 are vulnerable to Missing Cryptographic Step via the KJUR.cryp
- CVE-2026-4600 HIGH 7.4 UPGRADE Versions of the package jsrsasign before 11.1.1 are vulnerable to Improper Verification of Cryptographic Signa
- CVE-2026-4599 CRITICAL 9.1 UPGRADE Versions of the package jsrsasign from 7.0.0 and before 11.1.1 are vulnerable to Incomplete Comparison with Mi
- CVE-2026-4598 HIGH 7.5 UPGRADE Versions of the package jsrsasign before 11.1.1 are vulnerable to Infinite loop via the bnModInverse function
- CVE-2026-4603 MEDIUM 5.9 UPGRADE Versions of the package jsrsasign before 11.1.1 are vulnerable to Division by zero due to the RSASetPublic/KEY
FAQ
How do I fix jsrsasign vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is jsrsasign being exploited right now?
None of the tracked jsrsasign CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which jsrsasign CVE should I patch first?
CVE-2026-4599 currently ranks highest (52/100): Versions of the package jsrsasign from 7.0.0 and before 11.1.1 are vulnerable to Incomplete Comparison with Mi.