libnmap vulnerabilities and fixes
Recent CVEs affecting libnmap, with upgrade or downgrade steps. 2 tracked.
libnmap has 2 tracked vulnerabilities, 1 critical. A fixed release or vendor patch exists for 2. Most recent: 2019-07-15. Highest priority: CVE-2018-16461 (score 67/100).
- CVE-2019-1010017 HIGH 7.5 UPGRADE libnmap < v0.6.3 is affected by: XML Injection
- CVE-2018-16461 CRITICAL 9.8 UPGRADE A command injection vulnerability in libnmapp package for versions <0.4.16 allows arbitrary commands to be exe
FAQ
How do I fix libnmap vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is libnmap being exploited right now?
None of the tracked libnmap CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which libnmap CVE should I patch first?
CVE-2018-16461 currently ranks highest (67/100): A command injection vulnerability in libnmapp package for versions <0.4.16 allows arbitrary commands to be exe.