libvncserver vulnerabilities and fixes
Recent CVEs affecting libvncserver, with upgrade or downgrade steps. 2 tracked.
libvncserver has 2 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 2. Most recent: 2026-03-24. Highest priority: CVE-2026-32854 (score 59/100).
- CVE-2026-32854 HIGH 7.5 UPGRADE LibVNCServer versions 0.9.15 and prior (fixed in commit dc78dee) contain null pointer dereference vulnerabilit
- CVE-2026-32853 HIGH 8.1 UPGRADE LibVNCServer versions 0.9.15 and prior (fixed in commit 009008e) contain a heap out-of-bounds read vulnerabili
FAQ
How do I fix libvncserver vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is libvncserver being exploited right now?
None of the tracked libvncserver CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which libvncserver CVE should I patch first?
CVE-2026-32854 currently ranks highest (59/100): LibVNCServer versions 0.9.15 and prior (fixed in commit dc78dee) contain null pointer dereference vulnerabilit.