lynx vulnerabilities and fixes
Recent CVEs affecting lynx, with upgrade or downgrade steps. 5 tracked.
lynx has 5 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 2. Most recent: 2021-08-07. Highest priority: CVE-2016-9179 (score 51/100).
- CVE-2021-38165 MEDIUM 5.3 UPGRADE MITIGATE Lynx through 2.8.9 mishandles the userinfo subcomponent of a URI, which allows remote attackers to discover cl
- CVE-2017-1000211 MEDIUM 5.3 DOWNGRADE Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory disclosure, b
- CVE-2016-9179 HIGH 7.5 MITIGATE lynx: It was found that Lynx doesn't parse the authority component of the URL correctly when the host name par
- CVE-2014-5002 HIGH 7.8 UPGRADE The lynx gem before 1.0.0 for Ruby places the configured password on command lines, which allows local users t
- CVE-2012-5821 MEDIUM 5.9 MITIGATE MITIGATE Lynx does not verify that the server's certificate is signed by a trusted certification authority, which allow
FAQ
How do I fix lynx vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is lynx being exploited right now?
None of the tracked lynx CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which lynx CVE should I patch first?
CVE-2016-9179 currently ranks highest (51/100): lynx: It was found that Lynx doesn't parse the authority component of the URL correctly when the host name par.