mgetty vulnerabilities and fixes
Recent CVEs affecting mgetty, with upgrade or downgrade steps. 7 tracked.
mgetty has 7 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 7. Most recent: 2019-07-24. Highest priority: CVE-2018-16741 (score 55/100).
- CVE-2019-1010190 MEDIUM 5.5 UPGRADE mgetty prior to 1.2.1 is affected by: out-of-bounds read
- CVE-2019-1010189 MEDIUM 5.5 UPGRADE mgetty prior to version 1.2.1 is affected by: Infinite Loop
- CVE-2018-16745 HIGH 7.8 UPGRADE An issue was discovered in mgetty before 1.2.1
- CVE-2018-16744 HIGH 7.8 UPGRADE An issue was discovered in mgetty before 1.2.1
- CVE-2018-16743 HIGH 7.8 UPGRADE An issue was discovered in mgetty before 1.2.1
- CVE-2018-16742 HIGH 7.8 UPGRADE An issue was discovered in mgetty before 1.2.1
- CVE-2018-16741 HIGH 7.8 UPGRADE MITIGATE An issue was discovered in mgetty before 1.2.1
FAQ
How do I fix mgetty vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is mgetty being exploited right now?
None of the tracked mgetty CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which mgetty CVE should I patch first?
CVE-2018-16741 currently ranks highest (55/100): An issue was discovered in mgetty before 1.2.1.