modbus slave vulnerabilities and fixes
Recent CVEs affecting modbus slave, with upgrade or downgrade steps. 2 tracked.
Also searched as: modbusslave.
modbus slave has 2 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 2. Most recent: 2022-12-30. Highest priority: CVE-2022-4856 (score 39/100).
- CVE-2022-4856 MEDIUM 6.3 UPGRADE A vulnerability has been found in Modbus Tools Modbus Slave up to 7.5.1 and classified as critical
- CVE-2022-1068 MEDIUM 5.5 UPGRADE Modbus Tools Modbus Slave (versions 7.4.2 and prior) is vulnerable to a stack-based buffer overflow in the reg
FAQ
How do I fix modbus slave vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is modbus slave being exploited right now?
None of the tracked modbus slave CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which modbus slave CVE should I patch first?
CVE-2022-4856 currently ranks highest (39/100): A vulnerability has been found in Modbus Tools Modbus Slave up to 7.5.1 and classified as critical.