openidm vulnerabilities and fixes
Recent CVEs affecting openidm, with upgrade or downgrade steps. 3 tracked.
openidm has 3 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 3. Most recent: 2017-04-09. Highest priority: CVE-2017-7589 (score 44/100).
- CVE-2017-7591 MEDIUM 6.1 UPGRADE OpenIDM through 4.0.0 and 4.5.0 is vulnerable to reflected cross-site scripting (XSS) attacks within the Admin
- CVE-2017-7590 MEDIUM 6.1 UPGRADE OpenIDM through 4.0.0 and 4.5.0 is vulnerable to persistent cross-site scripting (XSS) attacks within the Admi
- CVE-2017-7589 MEDIUM 6.5 UPGRADE In OpenIDM through 4.0.0 before 4.5.0, the info endpoint may leak sensitive information upon a request by the
FAQ
How do I fix openidm vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is openidm being exploited right now?
None of the tracked openidm CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which openidm CVE should I patch first?
CVE-2017-7589 currently ranks highest (44/100): In OpenIDM through 4.0.0 before 4.5.0, the info endpoint may leak sensitive information upon a request by the .