p4 vulnerabilities and fixes
Recent CVEs affecting p4, with upgrade or downgrade steps. 3 tracked.
p4 has 3 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 3. Most recent: 2022-12-20. Highest priority: CVE-2022-25171 (score 52/100).
- CVE-2022-25171 HIGH 7.4 UPGRADE The package p4 before 0.0.7 are vulnerable to Command Injection via the run() function due to improper input s
- CVE-2021-21655 HIGH 7.1 UPGRADE A cross-site request forgery (CSRF) vulnerability in Jenkins P4 Plugin 1.11.4 and earlier allows attackers to
- CVE-2021-21654 MEDIUM 4.3 UPGRADE Jenkins P4 Plugin 1.11.4 and earlier does not perform permission checks in multiple HTTP endpoints, allowing a
FAQ
How do I fix p4 vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is p4 being exploited right now?
None of the tracked p4 CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which p4 CVE should I patch first?
CVE-2022-25171 currently ranks highest (52/100): The package p4 before 0.0.7 are vulnerable to Command Injection via the run() function due to improper input s.