pdfresurrect vulnerabilities and fixes
Recent CVEs affecting pdfresurrect, with upgrade or downgrade steps. 5 tracked.
pdfresurrect has 5 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 3. Most recent: 2021-04-28. Highest priority: CVE-2019-14267 (score 56/100).
- CVE-2021-3508 MEDIUM 5.5 DOWNGRADE A flaw was found in PDFResurrect in version 0.22b
- CVE-2020-9549 HIGH 7.8 UPGRADE MITIGATE In PDFResurrect 0.12 through 0.19, get_type in pdf.c has an out-of-bounds write via a crafted PDF document.
- CVE-2020-20740 HIGH 7.8 UPGRADE MITIGATE PDFResurrect before 0.20 lack of header validation checks causes heap-buffer-overflow in pdf_get_version().
- CVE-2019-14934 HIGH 7.8 UPGRADE MITIGATE An issue was discovered in PDFResurrect before 0.18
- CVE-2019-14267 HIGH 7.8 DOWNGRADE MITIGATE PDFResurrect 0.15 has a buffer overflow via a crafted PDF file because data associated with startxref and %%EO
FAQ
How do I fix pdfresurrect vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is pdfresurrect being exploited right now?
None of the tracked pdfresurrect CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which pdfresurrect CVE should I patch first?
CVE-2019-14267 currently ranks highest (56/100): PDFResurrect 0.15 has a buffer overflow via a crafted PDF file because data associated with startxref and %%EO.