plenti vulnerabilities and fixes
Recent CVEs affecting plenti, with upgrade or downgrade steps. 3 tracked.
plenti has 3 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 3. Most recent: 2025-03-12. Highest priority: CVE-2024-49380 (score 58/100).
- CVE-2025-26260 HIGH 8.8 UPGRADE Plenti <= 0.7.16 is vulnerable to code execution
- CVE-2024-49381 HIGH 7.5 UPGRADE Plenti, a static site generator, has an arbitrary file deletion vulnerability in versions prior to 0.7.2
- CVE-2024-49380 HIGH 7.5 UPGRADE Plenti, a static site generator, has an arbitrary file write vulnerability in versions prior to 0.7.2
FAQ
How do I fix plenti vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is plenti being exploited right now?
None of the tracked plenti CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which plenti CVE should I patch first?
CVE-2024-49380 currently ranks highest (58/100): Plenti, a static site generator, has an arbitrary file write vulnerability in versions prior to 0.7.2.