procps-ng vulnerabilities and fixes
Recent CVEs affecting procps-ng, with upgrade or downgrade steps. 5 tracked.
Also searched as: procps ng.
procps-ng has 5 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 5. Most recent: 2018-05-23. Highest priority: CVE-2018-1125 (score 61/100).
- CVE-2018-1126 MEDIUM 4.8 UPGRADE MITIGATE procps-ng before version 3.3.15 is vulnerable to an incorrect integer size in proc/alloc.* leading to truncati
- CVE-2018-1125 HIGH 7.5 UPGRADE MITIGATE procps-ng before version 3.3.15 is vulnerable to a stack buffer overflow in pgrep
- CVE-2018-1124 HIGH 7.8 UPGRADE MITIGATE procps-ng before version 3.3.15 is vulnerable to multiple integer overflows leading to a heap corruption in fi
- CVE-2018-1123 LOW 3.9 UPGRADE MITIGATE procps-ng before version 3.3.15 is vulnerable to a denial of service in ps via mmap buffer overflow
- CVE-2018-1122 HIGH 7.3 UPGRADE MITIGATE procps-ng before version 3.3.15 is vulnerable to a local privilege escalation in top
FAQ
How do I fix procps-ng vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is procps-ng being exploited right now?
None of the tracked procps-ng CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which procps-ng CVE should I patch first?
CVE-2018-1125 currently ranks highest (61/100): procps-ng before version 3.3.15 is vulnerable to a stack buffer overflow in pgrep.