qi blocks vulnerabilities and fixes
Recent CVEs affecting qi blocks, with upgrade or downgrade steps. 6 tracked.
Also searched as: qiblocks.
qi blocks has 6 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 6. Most recent: 2025-05-19. Highest priority: CVE-2024-49690 (score 38/100).
- CVE-2025-1627 MEDIUM 5.4 UPGRADE The Qi Blocks WordPress plugin before 1.4 does not validate and escape some of its block options before output
- CVE-2025-1626 MEDIUM 5.4 UPGRADE The Qi Blocks WordPress plugin before 1.4 does not validate and escape some of its Countdown block options bef
- CVE-2025-1625 MEDIUM 5.4 UPGRADE The Qi Blocks WordPress plugin before 1.4 does not validate and escape some of its Counter block options befor
- CVE-2024-5221 MEDIUM 6.4 UPGRADE The Qi Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's file uploader
- CVE-2024-49690 HIGH 7.5 UPGRADE Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulner
- CVE-2024-38712 MEDIUM 6.5 UPGRADE Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Qode Qi
FAQ
How do I fix qi blocks vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is qi blocks being exploited right now?
None of the tracked qi blocks CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which qi blocks CVE should I patch first?
CVE-2024-49690 currently ranks highest (38/100): Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulner.