safemode vulnerabilities and fixes
Recent CVEs affecting safemode, with upgrade or downgrade steps. 2 tracked.
safemode has 2 tracked vulnerabilities, 1 critical. A fixed release or vendor patch exists for 2. Most recent: 2017-07-21. Highest priority: CVE-2017-7540 (score 58/100).
- CVE-2017-7540 CRITICAL 9.8 UPGRADE rubygem-safemode, as used in Foreman, versions 1.3.2 and earlier are vulnerable to bypassing safe mode limitat
- CVE-2016-3693 HIGH 8.1 UPGRADE The Safemode gem before 1.2.4 for Ruby, when initialized with a delegate object that is a Rails controller, al
FAQ
How do I fix safemode vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is safemode being exploited right now?
None of the tracked safemode CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which safemode CVE should I patch first?
CVE-2017-7540 currently ranks highest (58/100): rubygem-safemode, as used in Foreman, versions 1.3.2 and earlier are vulnerable to bypassing safe mode limitat.