<?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="../assets/feed.xsl"?><rss version="2.0"><channel><title>PatchTheCVE: seata</title><link>https://patchthecve.com/</link><description>CVEs with upgrade or downgrade fix steps</description><item><title>CVE-2025-53606: Deserialization of Untrusted Data vulnerability in Apache Seata (incubating).

This issue affects Apache Seata</title><link>https://patchthecve.com/cve/CVE-2025-53606.html</link><guid>https://patchthecve.com/cve/CVE-2025-53606.html</guid><pubDate>Wed, 17 Jun 2026 09:38:34 +0000</pubDate><description>CRITICAL 9.8: Deserialization of Untrusted Data vulnerability in Apache Seata (incubating).

This issue affects Apache Seata (incubating): 2.4.0.

Users are recommended to upgrade to version 2.5.0, which fixes the issue.</description></item><item><title>CVE-2025-32897: Deserialization of Untrusted Data vulnerability in Apache Seata (incubating).

This security vulnerability is </title><link>https://patchthecve.com/cve/CVE-2025-32897.html</link><guid>https://patchthecve.com/cve/CVE-2025-32897.html</guid><pubDate>Wed, 17 Jun 2026 09:12:46 +0000</pubDate><description>CRITICAL 9.8: Deserialization of Untrusted Data vulnerability in Apache Seata (incubating).

This security vulnerability is the same as CVE-2024-47552, but the version range described in the CVE-2024-47552 definition is too narrow.
This issue affects Apache Seata (incubating): from 2.0.0 before 2.3.0.

Severity J</description></item><item><title>CVE-2024-54016: Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Seata (incubating).

</title><link>https://patchthecve.com/cve/CVE-2024-54016.html</link><guid>https://patchthecve.com/cve/CVE-2024-54016.html</guid><pubDate>Wed, 17 Jun 2026 08:09:40 +0000</pubDate><description>MEDIUM 4.3: Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Seata (incubating).

This issue affects Apache Seata (incubating): through &lt;=2.2.0.

Users are recommended to upgrade to version 2.3.0, which fixes the issue.</description></item><item><title>CVE-2024-47552: Deserialization of Untrusted Data vulnerability in Apache Seata (incubating).





This issue affects Apache S</title><link>https://patchthecve.com/cve/CVE-2024-47552.html</link><guid>https://patchthecve.com/cve/CVE-2024-47552.html</guid><pubDate>Wed, 17 Jun 2026 07:57:17 +0000</pubDate><description>CRITICAL 9.8: Deserialization of Untrusted Data vulnerability in Apache Seata (incubating).





This issue affects Apache Seata (incubating): from 2.0.0 before 2.2.0.





Severity Justification:

The Apache Seata security team assesses the severity of this vulnerability as &quot;Low&quot; due to stringent real-world miti</description></item><item><title>CVE-2024-22399: Deserialization of Untrusted Data vulnerability in Apache Seata. 

When developers disable authentication on t</title><link>https://patchthecve.com/cve/CVE-2024-22399.html</link><guid>https://patchthecve.com/cve/CVE-2024-22399.html</guid><pubDate>Wed, 17 Jun 2026 07:11:20 +0000</pubDate><description>CRITICAL 9.8: Deserialization of Untrusted Data vulnerability in Apache Seata. 

When developers disable authentication on the Seata-Server and do not use the Seata client SDK dependencies, they may construct uncontrolled serialized malicious requests by directly sending bytecode based on the Seata private protoc</description></item></channel></rss>