spamassassin vulnerabilities and fixes
Recent CVEs affecting spamassassin, with upgrade or downgrade steps. 16 tracked.
spamassassin has 16 tracked vulnerabilities, 2 critical. A fixed release or vendor patch exists for 10. Most recent: 2021-03-25. Highest priority: CVE-2020-1946 (score 68/100).
- CVE-2020-1946 CRITICAL 9.8 UPGRADE MITIGATE In Apache SpamAssassin before 3.4.5, malicious rule configuration (.cf) files can be configured to run system
- CVE-2020-1931 HIGH 8.1 UPGRADE A command execution issue was found in Apache SpamAssassin prior to 3.4.3
- CVE-2020-1930 HIGH 8.1 UPGRADE A command execution issue was found in Apache SpamAssassin prior to 3.4.3
- CVE-2019-12420 HIGH 7.5 UPGRADE MITIGATE In Apache SpamAssassin before 3.4.3, a message can be crafted in a way to use excessive resources
- CVE-2018-11805 MEDIUM 6.7 UPGRADE MITIGATE In Apache SpamAssassin before 3.4.3, nefarious CF files can be configured to run system commands without any o
- CVE-2018-11781 HIGH 7.8 UPGRADE MITIGATE Apache SpamAssassin 3.4.2 fixes a local user code injection in the meta rule syntax.
- CVE-2018-11780 CRITICAL 9.8 UPGRADE MITIGATE A potential Remote Code Execution bug exists with the PDFInfo plugin in Apache SpamAssassin before 3.4.2.
- CVE-2017-15705 MEDIUM 5.3 UPGRADE MITIGATE A denial of service vulnerability was identified that exists in Apache SpamAssassin before 3.4.2
- CVE-2016-1238 HIGH 7.8 MITIGATE MITIGATE (1) cpan/Archive-Tar/bin/ptar, (2) cpan/Archive-Tar/bin/ptardiff, (3) cpan/Archive-Tar/bin/ptargrep, (4) cpan/
- CVE-2007-2873 LOW 1.9 DOWNGRADE SpamAssassin 3.1.x, 3.2.0, and 3.2.1 before 20070611, when running as root in unusual configurations using vpo
- CVE-2007-0451 MEDIUM 4.3 UPGRADE Apache SpamAssassin before 3.1.8 allows remote attackers to cause a denial of service via long URLs in malform
- CVE-2006-2447 MEDIUM 5.1 DOWNGRADE SpamAssassin before 3.1.3, when running with vpopmail and the paranoid (-P) switch, allows remote attackers to
- CVE-2005-3351 MEDIUM 5.0 DOWNGRADE SpamAssassin 3.0.4 allows attackers to bypass spam detection via an e-mail with a large number of recipients (
- CVE-2005-1266 MEDIUM 5.0 DOWNGRADE Apache SpamAssassin 3.0.1, 3.0.2, and 3.0.3 allows remote attackers to cause a denial of service (CPU consumpt
- CVE-2004-0796 MEDIUM 5.0 DOWNGRADE SpamAssassin 2.5x, and 2.6x before 2.64, allows remote attackers to cause a denial of service via certain malf
- CVE-2003-1557 HIGH 7.6 DOWNGRADE Off-by-one buffer overflow in spamc of SpamAssassin 2.40 through 2.43, when using BSMTP mode ("-B"), allows re
FAQ
How do I fix spamassassin vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is spamassassin being exploited right now?
None of the tracked spamassassin CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which spamassassin CVE should I patch first?
CVE-2020-1946 currently ranks highest (68/100): In Apache SpamAssassin before 3.4.5, malicious rule configuration (.cf) files can be configured to run system .