ssri vulnerabilities and fixes
Recent CVEs affecting ssri, with upgrade or downgrade steps. 2 tracked.
ssri has 2 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 2. Most recent: 2021-03-12. Highest priority: CVE-2021-27290 (score 59/100).
- CVE-2021-27290 HIGH 7.5 UPGRADE DOWNGRADE ssri 5.2.2-8.0.0, fixed in 8.0.1, processes SRIs using a regular expression which is vulnerable to a denial of
- CVE-2018-7651 MEDIUM 5.9 UPGRADE index.js in the ssri module before 5.2.2 for Node.js is prone to a regular expression denial of service vulner
FAQ
How do I fix ssri vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is ssri being exploited right now?
None of the tracked ssri CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which ssri CVE should I patch first?
CVE-2021-27290 currently ranks highest (59/100): ssri 5.2.2-8.0.0, fixed in 8.0.1, processes SRIs using a regular expression which is vulnerable to a denial of.