terser vulnerabilities and fixes
Recent CVEs affecting terser, with upgrade or downgrade steps. 1 tracked.
terser has 1 tracked vulnerability, 0 critical. A fixed release or vendor patch exists for 1. Most recent: 2022-07-15. Highest priority: CVE-2022-25858 (score 51/100).
- CVE-2022-25858 MEDIUM 5.3 UPGRADE The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of S
FAQ
How do I fix terser vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is terser being exploited right now?
None of the tracked terser CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which terser CVE should I patch first?
CVE-2022-25858 currently ranks highest (51/100): The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of S.