underconstruction vulnerabilities and fixes
Recent CVEs affecting underconstruction, with upgrade or downgrade steps. 3 tracked.
underconstruction has 3 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 3. Most recent: 2022-06-20. Highest priority: CVE-2021-39320 (score 42/100).
- CVE-2022-1896 MEDIUM 4.8 UPGRADE The underConstruction WordPress plugin before 1.21 does not sanitise or escape the "Display a custom page usin
- CVE-2022-1895 MEDIUM 4.3 UPGRADE The underConstruction WordPress plugin before 1.20 does not have CSRF check in place when deactivating the con
- CVE-2021-39320 MEDIUM 6.1 UPGRADE The underConstruction plugin <= 1.18 for WordPress echoes out the raw value of `$GLOBALS['PHP_SELF']` in the u
FAQ
How do I fix underconstruction vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is underconstruction being exploited right now?
None of the tracked underconstruction CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which underconstruction CVE should I patch first?
CVE-2021-39320 currently ranks highest (42/100): The underConstruction plugin <= 1.18 for WordPress echoes out the raw value of `$GLOBALS['PHP_SELF']` in the u.