<?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="../assets/feed.xsl"?><rss version="2.0"><channel><title>PatchTheCVE: vagrant</title><link>https://patchthecve.com/</link><description>CVEs with upgrade or downgrade fix steps</description><item><title>CVE-2023-5834: HashiCorp Vagrant&#x27;s Windows installer targeted a custom location with a non-protected path that could be junct</title><link>https://patchthecve.com/cve/CVE-2023-5834.html</link><guid>https://patchthecve.com/cve/CVE-2023-5834.html</guid><pubDate>Wed, 17 Jun 2026 06:49:28 +0000</pubDate><description>LOW 3.8: HashiCorp Vagrant&#x27;s Windows installer targeted a custom location with a non-protected path that could be junctioned, introducing potential for unauthorized file system writes. Fixed in Vagrant 2.4.0.</description></item><item><title>CVE-2022-42717: An issue was discovered in Hashicorp Packer before 2.3.1</title><link>https://patchthecve.com/cve/CVE-2022-42717.html</link><guid>https://patchthecve.com/cve/CVE-2022-42717.html</guid><pubDate>Wed, 17 Jun 2026 05:05:10 +0000</pubDate><description>HIGH 7.8: An issue was discovered in Hashicorp Packer before 2.3.1. The recommended sudoers configuration for Vagrant on Linux is insecure. If the host has been configured according to this documentation, non-privileged users on the host can leverage a wildcard in the sudoers configuration to execute arbitrar</description></item><item><title>CVE-2021-21361: The `com.bmuschko:gradle-vagrant-plugin` Gradle plugin contains an information disclosure vulnerability due to</title><link>https://patchthecve.com/cve/CVE-2021-21361.html</link><guid>https://patchthecve.com/cve/CVE-2021-21361.html</guid><pubDate>Wed, 17 Jun 2026 03:35:23 +0000</pubDate><description>MEDIUM 5.3: The `com.bmuschko:gradle-vagrant-plugin` Gradle plugin contains an information disclosure vulnerability due to the logging of the system environment variables. When this Gradle plugin is executed in public CI/CD, this can lead to sensitive credentials being exposed to malicious actors. This is fixed</description></item><item><title>CVE-2017-16777: If HashiCorp Vagrant VMware Fusion plugin (aka vagrant-vmware-fusion) 5.0.3 is installed but VMware Fusion is </title><link>https://patchthecve.com/cve/CVE-2017-16777.html</link><guid>https://patchthecve.com/cve/CVE-2017-16777.html</guid><pubDate>Wed, 17 Jun 2026 01:09:54 +0000</pubDate><description>HIGH 7.8: If HashiCorp Vagrant VMware Fusion plugin (aka vagrant-vmware-fusion) 5.0.3 is installed but VMware Fusion is not, a local attacker can create a fake application directory and exploit the suid sudo helper in order to escalate to root.</description></item><item><title>CVE-2017-16001: In HashiCorp Vagrant VMware Fusion plugin (aka vagrant-vmware-fusion) 5.0.1, a local attacker or malware can s</title><link>https://patchthecve.com/cve/CVE-2017-16001.html</link><guid>https://patchthecve.com/cve/CVE-2017-16001.html</guid><pubDate>Wed, 17 Jun 2026 01:08:37 +0000</pubDate><description>HIGH 7.8: In HashiCorp Vagrant VMware Fusion plugin (aka vagrant-vmware-fusion) 5.0.1, a local attacker or malware can silently subvert the plugin update process in order to escalate to root privileges.</description></item></channel></rss>