<?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="../assets/feed.xsl"?><rss version="2.0"><channel><title>PatchTheCVE: varnish cache</title><link>https://patchthecve.com/</link><description>CVEs with upgrade or downgrade fix steps</description><item><title>CVE-2022-45060: An HTTP Request Forgery issue was discovered in Varnish Cache 5.x and 6.x before 6.0.11, 7.x before 7.1.2, and</title><link>https://patchthecve.com/cve/CVE-2022-45060.html</link><guid>https://patchthecve.com/cve/CVE-2022-45060.html</guid><pubDate>Wed, 17 Jun 2026 05:09:16 +0000</pubDate><description>HIGH 7.5: An HTTP Request Forgery issue was discovered in Varnish Cache 5.x and 6.x before 6.0.11, 7.x before 7.1.2, and 7.2.x before 7.2.1. An attacker may introduce characters through HTTP/2 pseudo-headers that are invalid in the context of an HTTP/1 request line, causing the Varnish server to produce inval</description></item><item><title>CVE-2022-45059: An issue was discovered in Varnish Cache 7.x before 7.1.2 and 7.2.x before 7.2.1</title><link>https://patchthecve.com/cve/CVE-2022-45059.html</link><guid>https://patchthecve.com/cve/CVE-2022-45059.html</guid><pubDate>Wed, 17 Jun 2026 05:09:15 +0000</pubDate><description>HIGH 7.5: An issue was discovered in Varnish Cache 7.x before 7.1.2 and 7.2.x before 7.2.1. A request smuggling attack can be performed on Varnish Cache servers by requesting that certain headers are made hop-by-hop, preventing the Varnish Cache servers from forwarding critical headers to the backend.</description></item><item><title>CVE-2022-38150: In Varnish Cache 7.0.0, 7.0.1, 7.0.2, and 7.1.0, it is possible to cause the Varnish Server to assert and auto</title><link>https://patchthecve.com/cve/CVE-2022-38150.html</link><guid>https://patchthecve.com/cve/CVE-2022-38150.html</guid><pubDate>Wed, 17 Jun 2026 04:56:11 +0000</pubDate><description>HIGH 7.5: In Varnish Cache 7.0.0, 7.0.1, 7.0.2, and 7.1.0, it is possible to cause the Varnish Server to assert and automatically restart through forged HTTP/1 backend responses. An attack uses a crafted reason phrase of the backend response status line. This is fixed in 7.0.3 and 7.1.1.</description></item><item><title>CVE-2022-23959: In Varnish Cache before 6.6.2 and 7.x before 7.0.2, Varnish Cache 6.0 LTS before 6.0.10, and and Varnish Enter</title><link>https://patchthecve.com/cve/CVE-2022-23959.html</link><guid>https://patchthecve.com/cve/CVE-2022-23959.html</guid><pubDate>Wed, 17 Jun 2026 04:31:03 +0000</pubDate><description>CRITICAL 9.1: In Varnish Cache before 6.6.2 and 7.x before 7.0.2, Varnish Cache 6.0 LTS before 6.0.10, and and Varnish Enterprise (Cache Plus) 4.1.x before 4.1.11r6 and 6.0.x before 6.0.9r4, request smuggling can occur for HTTP/1 connections.</description></item><item><title>CVE-2021-36740: Varnish Cache, with HTTP/2 enabled, allows request smuggling and VCL authorization bypass via a large Content-</title><link>https://patchthecve.com/cve/CVE-2021-36740.html</link><guid>https://patchthecve.com/cve/CVE-2021-36740.html</guid><pubDate>Wed, 17 Jun 2026 03:59:05 +0000</pubDate><description>MEDIUM 6.5: Varnish Cache, with HTTP/2 enabled, allows request smuggling and VCL authorization bypass via a large Content-Length header for a POST request. This affects Varnish Enterprise 6.0.x before 6.0.8r3, and Varnish Cache 5.x and 6.x before 6.5.2, 6.6.x before 6.6.1, and 6.0 LTS before 6.0.8.</description></item><item><title>CVE-2020-11653: An issue was discovered in Varnish Cache before 6.0.6 LTS, 6.1.x and 6.2.x before 6.2.3, and 6.3.x before 6.3.</title><link>https://patchthecve.com/cve/CVE-2020-11653.html</link><guid>https://patchthecve.com/cve/CVE-2020-11653.html</guid><pubDate>Wed, 17 Jun 2026 02:50:33 +0000</pubDate><description>HIGH 7.5: An issue was discovered in Varnish Cache before 6.0.6 LTS, 6.1.x and 6.2.x before 6.2.3, and 6.3.x before 6.3.2. It occurs when communication with a TLS termination proxy uses PROXY version 2. There can be an assertion failure and daemon restart, which causes a performance loss.</description></item><item><title>CVE-2019-20637: An issue was discovered in Varnish Cache before 6.0.5 LTS, 6.1.x and 6.2.x before 6.2.2, and 6.3.x before 6.3.</title><link>https://patchthecve.com/cve/CVE-2019-20637.html</link><guid>https://patchthecve.com/cve/CVE-2019-20637.html</guid><pubDate>Wed, 17 Jun 2026 02:30:51 +0000</pubDate><description>HIGH 7.5: An issue was discovered in Varnish Cache before 6.0.5 LTS, 6.1.x and 6.2.x before 6.2.2, and 6.3.x before 6.3.1. It does not clear a pointer between the handling of one client request and the next request within the same connection. This sometimes causes information to be disclosed from the connecti</description></item></channel></rss>