vcftools vulnerabilities and fixes
Recent CVEs affecting vcftools, with upgrade or downgrade steps. 4 tracked.
vcftools has 4 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 1. Most recent: 2019-07-25. Highest priority: CVE-2018-11130 (score 52/100).
- CVE-2019-1010127 HIGH 7.8 UPGRADE VCFTools vcftools prior to version 0.1.15 is affected by: Use-after-free
- CVE-2018-11130 HIGH 7.8 DOWNGRADE The header::add_FORMAT_descriptor function in header.cpp in VCFtools 0.1.15 allows remote attackers to cause a
- CVE-2018-11129 HIGH 7.8 DOWNGRADE The header::add_INFO_descriptor function in header.cpp in VCFtools 0.1.15 allows remote attackers to cause a d
- CVE-2018-11099 MEDIUM 5.5 DOWNGRADE The header::add_INFO_descriptor function in header.cpp in VCFtools 0.1.15 allows remote attackers to cause inf
FAQ
How do I fix vcftools vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is vcftools being exploited right now?
None of the tracked vcftools CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which vcftools CVE should I patch first?
CVE-2018-11130 currently ranks highest (52/100): The header::add_FORMAT_descriptor function in header.cpp in VCFtools 0.1.15 allows remote attackers to cause a.