webgalamb vulnerabilities and fixes
Recent CVEs affecting webgalamb, with upgrade or downgrade steps. 7 tracked.
webgalamb has 7 tracked vulnerabilities, 3 critical. A fixed release or vendor patch exists for 5. Most recent: 2019-03-21. Highest priority: CVE-2018-19510 (score 69/100).
- CVE-2018-19515 CRITICAL 9.8 UPGRADE In Webgalamb through 7.0, system/ajax.php functionality is supposed to be available only to the administrator
- CVE-2018-19514 CRITICAL 9.8 UPGRADE In Webgalamb through 7.0, an arbitrary code execution vulnerability could be exploited remotely without authen
- CVE-2018-19513 HIGH 7.5 UPGRADE In Webgalamb through 7.0, log files are exposed to the internet with predictable files/logs/sql_error_log/YYYY
- CVE-2018-19512 HIGH 7.2 UPGRADE In Webgalamb through 7.0, a system/ajax.php "wgmfile restore" directory traversal vulnerability could lead to
- CVE-2018-19511 MEDIUM 6.5 DOWNGRADE wg7.php in Webgalamb 7.0 lacks security measures to prevent CSRF attacks, as demonstrated by wg7.php?options=1
- CVE-2018-19510 CRITICAL 9.8 UPGRADE subscriber.php in Webgalamb through 7.0 is vulnerable to SQL injection via the Client-IP HTTP request header.
- CVE-2018-19509 MEDIUM 6.1 DOWNGRADE wg7.php in Webgalamb 7.0 makes opportunistic calls to htmlspecialchars() instead of using a templating engine
FAQ
How do I fix webgalamb vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is webgalamb being exploited right now?
None of the tracked webgalamb CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which webgalamb CVE should I patch first?
CVE-2018-19510 currently ranks highest (69/100): subscriber.php in Webgalamb through 7.0 is vulnerable to SQL injection via the Client-IP HTTP request header..