xampp vulnerabilities and fixes
Recent CVEs affecting xampp, with upgrade or downgrade steps. 2 tracked.
xampp has 2 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 2. Most recent: 2024-02-02. Highest priority: CVE-2024-0338 (score 41/100).
- CVE-2024-0338 HIGH 7.3 UPGRADE A buffer overflow vulnerability has been found in XAMPP affecting version 8.2.4 and earlier
- CVE-2022-47637 MEDIUM 6.7 UPGRADE The installer in XAMPP through 8.1.12 allows local users to write to the C:\xampp directory
FAQ
How do I fix xampp vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is xampp being exploited right now?
None of the tracked xampp CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which xampp CVE should I patch first?
CVE-2024-0338 currently ranks highest (41/100): A buffer overflow vulnerability has been found in XAMPP affecting version 8.2.4 and earlier.