<?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="../assets/feed.xsl"?><rss version="2.0"><channel><title>PatchTheCVE: yii</title><link>https://patchthecve.com/</link><description>CVEs with upgrade or downgrade fix steps</description><item><title>CVE-2025-32027: Yii is an open source PHP web framework</title><link>https://patchthecve.com/cve/CVE-2025-32027.html</link><guid>https://patchthecve.com/cve/CVE-2025-32027.html</guid><pubDate>Wed, 17 Jun 2026 09:11:20 +0000</pubDate><description>MEDIUM 6.1: Yii is an open source PHP web framework. Prior to 1.1.31, yiisoft/yii is vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used. Upgrade yiisoft/yii to version 1.1.31 or higher.</description></item><item><title>CVE-2024-58136: Yiiframework Yii Improper Protection of Alternate Path Vulnerability</title><link>https://patchthecve.com/cve/CVE-2024-58136.html</link><guid>https://patchthecve.com/cve/CVE-2024-58136.html</guid><pubDate>Wed, 17 Jun 2026 08:14:41 +0000</pubDate><description>CRITICAL 9.0: Yii 2 before 2.0.52 mishandles the attaching of behavior that is defined by an __class array key, a CVE-2024-4990 regression, as exploited in the wild in February through April 2025.</description></item><item><title>CVE-2025-2690: A vulnerability, which was classified as critical, was found in yiisoft Yii2 up to 2.0.39</title><link>https://patchthecve.com/cve/CVE-2025-2690.html</link><guid>https://patchthecve.com/cve/CVE-2025-2690.html</guid><pubDate>Wed, 17 Jun 2026 09:07:27 +0000</pubDate><description>MEDIUM 6.3: A vulnerability, which was classified as critical, was found in yiisoft Yii2 up to 2.0.39. This affects the function Generate of the file phpunit\src\Framework\MockObject\MockClass.php. The manipulation leads to deserialization. It is possible to initiate the attack remotely. The exploit has been di</description></item><item><title>CVE-2025-2689: A vulnerability, which was classified as critical, has been found in yiisoft Yii2 up to 2.0.45</title><link>https://patchthecve.com/cve/CVE-2025-2689.html</link><guid>https://patchthecve.com/cve/CVE-2025-2689.html</guid><pubDate>Wed, 17 Jun 2026 09:07:26 +0000</pubDate><description>MEDIUM 6.3: A vulnerability, which was classified as critical, has been found in yiisoft Yii2 up to 2.0.45. Affected by this issue is the function getIterator of the file symfony\finder\Iterator\SortableIterator.php. The manipulation leads to deserialization. The attack may be launched remotely. The exploit has</description></item><item><title>CVE-2024-4990: In yiisoft/yii2 version 2.0.48, the base Component class contains a vulnerability where the `__set()` magic me</title><link>https://patchthecve.com/cve/CVE-2024-4990.html</link><guid>https://patchthecve.com/cve/CVE-2024-4990.html</guid><pubDate>Wed, 17 Jun 2026 08:03:20 +0000</pubDate><description>CRITICAL 9.1: In yiisoft/yii2 version 2.0.48, the base Component class contains a vulnerability where the `__set()` magic method does not validate that the value passed is a valid Behavior class name or configuration. This allows an attacker to instantiate arbitrary classes, passing parameters to their constructo</description></item><item><title>CVE-2024-32877: Yii 2 is a PHP application framework</title><link>https://patchthecve.com/cve/CVE-2024-32877.html</link><guid>https://patchthecve.com/cve/CVE-2024-32877.html</guid><pubDate>Wed, 17 Jun 2026 07:30:36 +0000</pubDate><description>MEDIUM 4.2: Yii 2 is a PHP application framework. During internal penetration testing of a product based on Yii2, users discovered a Cross-site Scripting (XSS) vulnerability within the framework itself. This issue is relevant for the latest version of Yii2 (2.0.49.3). This issue lies in the mechanism for displa</description></item><item><title>CVE-2023-47130: Yii is an open source PHP web framework</title><link>https://patchthecve.com/cve/CVE-2023-47130.html</link><guid>https://patchthecve.com/cve/CVE-2023-47130.html</guid><pubDate>Wed, 17 Jun 2026 06:32:13 +0000</pubDate><description>HIGH 8.1: Yii is an open source PHP web framework. yiisoft/yii before version 1.1.29 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. An attacker may leverage this vulnerability to compromise the host system. A fix has been developed for the 1.1.2</description></item></channel></rss>