CVEs published by Pivotal Software, Inc.
CVEs published by Pivotal Software, Inc. (CVE Numbering Authority). 31 tracked.
- CVE-2020-5421 MEDIUM 6.5 UPGRADE DOWNGRADE In Spring Framework versions 5.2.0 - 5.2.8, 5.1.0 - 5.1.17, 5.0.0 - 5.0.18, 4.3.0 - 4.3.28, and older unsuppor
- CVE-2020-5403 HIGH 7.5 DOWNGRADE Reactor Netty HttpServer, versions 0.9.3 and 0.9.4, is exposed to a URISyntaxException that causes the connect
- CVE-2020-5404 MEDIUM 5.9 UPGRADE The HttpClient from Reactor Netty, versions 0.9.x prior to 0.9.5, and versions 0.8.x prior to 0.8.16, may be u
- CVE-2020-5411 HIGH 8.1 UPGRADE When configured to enable default typing, Jackson contained a deserialization vulnerability that could lead to
- CVE-2020-5428 MEDIUM 6.0 UPGRADE In applications using Spring Cloud Task 2.2.4.RELEASE and below, may be vulnerable to SQL injection when exerc
- CVE-2020-5427 HIGH 7.2 UPGRADE In Spring Cloud Data Flow, versions 2.6.x prior to 2.6.5, versions 2.5.x prior 2.5.4, an application is vulner
- CVE-2020-5426 CRITICAL 9.8 UPGRADE Scheduler for TAS prior to version 1.4.0 was permitting plaintext transmission of UAA client token by sending
- CVE-2020-5425 HIGH 7.9 UPGRADE Single Sign-On for Vmware Tanzu all versions prior to 1.11.3 ,1.12.x versions prior to 1.12.4 and 1.13.x prior
- CVE-2020-5423 HIGH 7.5 UPGRADE UPGRADE CAPI (Cloud Controller) versions prior to 1.101.0 are vulnerable to a denial-of-service attack in which an una
- CVE-2020-5422 MEDIUM 6.5 UPGRADE BOSH System Metrics Server releases prior to 0.1.0 exposed the UAA password as a flag to a process running on
- CVE-2020-5420 HIGH 7.7 UPGRADE UPGRADE Cloud Foundry Routing (Gorouter) versions prior to 0.206.0 allow a malicious developer with "cf push" access t
- CVE-2020-5419 MEDIUM 6.7 UPGRADE UPGRADE RabbitMQ versions 3.8.x prior to 3.8.7 are prone to a Windows-specific binary planting security vulnerability
- CVE-2020-5418 MEDIUM 4.3 UPGRADE UPGRADE Cloud Foundry CAPI (Cloud Controller) versions prior to 1.98.0 allow authenticated users having only the "clou
- CVE-2020-5417 HIGH 8.8 UPGRADE UPGRADE Cloud Foundry CAPI (Cloud Controller), versions prior to 1.97.0, when used in a deployment where an app domain
- CVE-2020-5416 MEDIUM 6.5 UPGRADE UPGRADE Cloud Foundry Routing (Gorouter), versions prior to 0.204.0, when used in a deployment with NGINX reverse prox
- CVE-2020-5415 CRITICAL 10.0 UPGRADE Concourse, versions prior to 6.3.1 and 6.4.1, in installations which use the GitLab auth connector, is vulnera
- CVE-2020-5414 MEDIUM 5.7 UPGRADE UPGRADE VMware Tanzu Application Service for VMs (2.7.x versions prior to 2.7.19, 2.8.x versions prior to 2.8.13, and
- CVE-2020-5413 CRITICAL 9.8 UPGRADE DOWNGRADE Spring Integration framework provides Kryo Codec implementations as an alternative for Java (de)serialization
- CVE-2020-5412 MEDIUM 6.5 UPGRADE Spring Cloud Netflix, versions 2.2.x prior to 2.2.4, versions 2.1.x prior to 2.1.6, and older unsupported vers
- CVE-2020-5410 HIGH 7.5 EXPLOITED UPGRADE VMware Tanzu Spring Cloud Config Directory Traversal Vulnerability
- CVE-2020-5409 MEDIUM 6.1 UPGRADE Pivotal Concourse, most versions prior to 6.0.0, allows redirects to untrusted websites in its login flow
- CVE-2020-5408 MEDIUM 6.5 UPGRADE UPGRADE Spring Security versions 5.3.x prior to 5.3.2, 5.2.x prior to 5.2.4, 5.1.x prior to 5.1.10, 5.0.x prior to 5.0
- CVE-2020-5407 HIGH 8.8 UPGRADE Spring Security versions 5.2.x prior to 5.2.4 and 5.3.x prior to 5.3.2 contain a signature wrapping vulnerabil
- CVE-2020-5406 MEDIUM 6.5 UPGRADE VMware Tanzu Application Service for VMs, 2.6.x versions prior to 2.6.18, 2.7.x versions prior to 2.7.11, and
- CVE-2020-5405 MEDIUM 6.5 UPGRADE Spring Cloud Config, versions 2.2.x prior to 2.2.2, versions 2.1.x prior to 2.1.7, and older unsupported versi
- CVE-2020-5402 HIGH 8.8 UPGRADE UPGRADE In Cloud Foundry UAA, versions prior to 74.14.0, a CSRF vulnerability exists due to the OAuth2 state parameter
- CVE-2020-5401 MEDIUM 5.3 UPGRADE Cloud Foundry Routing Release, versions prior to 0.197.0, contains GoRouter, which allows malicious clients to
- CVE-2020-5400 MEDIUM 6.5 UPGRADE UPGRADE Cloud Foundry Cloud Controller (CAPI), versions prior to 1.91.0, logs properties of background jobs when they
- CVE-2020-5399 HIGH 7.4 UPGRADE UPGRADE Cloud Foundry CredHub, versions prior to 2.5.10, connects to a MySQL database without TLS even when configured
- CVE-2020-5396 HIGH 8.8 UPGRADE UPGRADE VMware GemFire versions prior to 9.10.0, 9.9.2, 9.8.7, and 9.7.6, and VMware Tanzu GemFire for VMs versions pr
- CVE-2019-11286 CRITICAL 9.1 UPGRADE UPGRADE VMware GemFire versions prior to 9.10.0, 9.9.1, 9.8.5, and 9.7.5, and VMware Tanzu GemFire for VMs versions pr