alpinelinux vulnerabilities
Recent CVEs affecting alpinelinux products. 6 tracked.
alpinelinux has 6 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 4. Most recent: 2021-07-05. Highest priority: CVE-2018-1000849 (score 63/100).
- CVE-2021-36158 MEDIUM 5.9 UPGRADE In the xrdp package (in branches through 3.14) for Alpine Linux, RDP sessions are vulnerable to man-in-the-mid
- CVE-2021-30139 HIGH 7.5 UPGRADE In Alpine Linux apk-tools before 2.12.5, the tarball parser allows a buffer overflow and crash.
- CVE-2019-12875 MEDIUM 6.5 UPGRADE Alpine Linux abuild through 3.4.0 allows an unprivileged member of the abuild group to add an untrusted packag
- CVE-2018-1000849 HIGH 8.8 UPGRADE Alpine Linux version Versions prior to 2.6.10, 2.7.6, and 2.10.1 contains a Other/Unknown vulnerability in apk
- CVE-2017-9671 HIGH 7.8 MITIGATE A heap overflow in apk (Alpine Linux's package manager) allows a remote attacker to cause a denial of service,
- CVE-2017-9669 HIGH 7.8 MITIGATE A heap overflow in apk (Alpine Linux's package manager) allows a remote attacker to cause a denial of service,
FAQ
How do I fix alpinelinux vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is alpinelinux being exploited right now?
None of the tracked alpinelinux CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which alpinelinux CVE should I patch first?
CVE-2018-1000849 currently ranks highest (63/100): Alpine Linux version Versions prior to 2.6.10, 2.7.6, and 2.10.1 contains a Other/Unknown vulnerability in apk.