barix vulnerabilities
Recent CVEs affecting barix products. 2 tracked.
barix has 2 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 1. Most recent: 2025-12-08. Highest priority: CVE-2025-65231 (score 30/100).
- CVE-2025-65230 MEDIUM 5.4 MITIGATE Barix Instreamer v04.06 and v04.05 contains a stored cross-site scripting (XSS) vulnerability in the Web UI Co
- CVE-2025-65231 MEDIUM 6.1 UPGRADE Barix Instreamer v04.06 and earlier is vulnerable to Cross Site Scripting (XSS) in the Web UI I/O & Serial con
FAQ
How do I fix barix vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is barix being exploited right now?
None of the tracked barix CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which barix CVE should I patch first?
CVE-2025-65231 currently ranks highest (30/100): Barix Instreamer v04.06 and earlier is vulnerable to Cross Site Scripting (XSS) in the Web UI I/O & Serial con.