cherokee-project vulnerabilities
Recent CVEs affecting cherokee-project products. 4 tracked.
cherokee-project has 4 tracked vulnerabilities, 1 critical. A fixed release or vendor patch exists for 4. Most recent: 2020-07-27. Highest priority: CVE-2019-20800 (score 65/100).
- CVE-2020-12845 HIGH 7.5 UPGRADE Cherokee 0.4.27 to 1.2.104 is affected by a denial of service due to a NULL pointer dereferences
- CVE-2019-20800 CRITICAL 9.8 UPGRADE In Cherokee through 1.2.104, remote attackers can trigger an out-of-bounds write in cherokee_handler_cgi_add_e
- CVE-2019-20799 HIGH 7.5 UPGRADE In Cherokee through 1.2.104, multiple memory corruption errors may be used by a remote attacker to destabilize
- CVE-2019-20798 HIGH 8.4 UPGRADE An XSS issue was discovered in handler_server_info.c in Cherokee through 1.2.104
FAQ
How do I fix cherokee-project vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is cherokee-project being exploited right now?
None of the tracked cherokee-project CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which cherokee-project CVE should I patch first?
CVE-2019-20800 currently ranks highest (65/100): In Cherokee through 1.2.104, remote attackers can trigger an out-of-bounds write in cherokee_handler_cgi_add_e.