cksource vulnerabilities
Recent CVEs affecting cksource products. 4 tracked.
cksource has 4 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 2. Most recent: 2026-01-28. Highest priority: CVE-2025-63830 (score 31/100).
- CVE-2025-63830 MEDIUM 6.1 DOWNGRADE CKFinder 1.4.3 is vulnerable to Cross Site Scripting (XSS) in the File Upload function
- CVE-2025-13980 MEDIUM 5.3 UPGRADE Authentication Bypass Using an Alternate Path or Channel vulnerability in Drupal CKEditor 5 Premium Features a
- CVE-2024-13245 MEDIUM 5.4 DOWNGRADE Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal C
- CVE-2016-20023 MEDIUM 5.0 UPGRADE In CKSource CKFinder before 2.5.0.1 for ASP.NET, authenticated users could download any file from the server i
FAQ
How do I fix cksource vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is cksource being exploited right now?
None of the tracked cksource CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which cksource CVE should I patch first?
CVE-2025-63830 currently ranks highest (31/100): CKFinder 1.4.3 is vulnerable to Cross Site Scripting (XSS) in the File Upload function.