classcms vulnerabilities
Recent CVEs affecting classcms products. 7 tracked.
classcms has 7 tracked vulnerabilities, 2 critical. A fixed release or vendor patch exists for 2. Most recent: 2025-02-03. Highest priority: CVE-2024-57099 (score 58/100).
- CVE-2024-8145 LOW 2.4 DOWNGRADE A vulnerability, which was classified as problematic, has been found in ClassCMS 4.8
- CVE-2024-8144 LOW 3.5 DOWNGRADE A vulnerability classified as problematic was found in ClassCMS 4.8
- CVE-2024-57099 CRITICAL 9.8 DOWNGRADE ClassCMS v4.8 has a code execution vulnerability
- CVE-2024-57097 MEDIUM 4.8 DOWNGRADE ClassCMS 4.8 is vulnerable to Cross Site Scripting (XSS) in class/admin/channel.php.
- CVE-2024-48180 CRITICAL 9.8 UPGRADE ClassCMS <=4.8 is vulnerable to file inclusion in the nowView method in/class/cms/cms.php, which can include a
- CVE-2024-12666 MEDIUM 4.7 UPGRADE A vulnerability has been found in ClassCMS up to 4.8 and classified as critical
- CVE-2024-12503 LOW 2.4 DOWNGRADE A vulnerability classified as problematic was found in ClassCMS 4.8
FAQ
How do I fix classcms vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is classcms being exploited right now?
None of the tracked classcms CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which classcms CVE should I patch first?
CVE-2024-57099 currently ranks highest (58/100): ClassCMS v4.8 has a code execution vulnerability.