cygwin vulnerabilities
Recent CVEs affecting cygwin products. 3 tracked.
cygwin has 3 tracked vulnerabilities, 1 critical. A fixed release or vendor patch exists for 2. Most recent: 2021-04-29. Highest priority: CVE-2016-3067 (score 60/100).
- CVE-2021-29468 HIGH 8.8 UPGRADE Cygwin Git is a patch set for the git command line tool for the cygwin environment
- CVE-2017-7523 HIGH 7.5 DOWNGRADE Cygwin versions 1.7.2 up to and including 1.8.0 are vulnerable to buffer overflow vulnerability in wcsxfrm/wcs
- CVE-2016-3067 CRITICAL 9.8 UPGRADE Cygwin before 2.5.0 does not properly handle updating permissions when changing users, which allows attackers
FAQ
How do I fix cygwin vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is cygwin being exploited right now?
None of the tracked cygwin CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which cygwin CVE should I patch first?
CVE-2016-3067 currently ranks highest (60/100): Cygwin before 2.5.0 does not properly handle updating permissions when changing users, which allows attackers .