htmlunit vulnerabilities
Recent CVEs affecting htmlunit products. 5 tracked.
htmlunit has 5 tracked vulnerabilities, 2 critical. A fixed release or vendor patch exists for 5. Most recent: 2023-12-04. Highest priority: CVE-2023-26119 (score 65/100).
- CVE-2023-26119 CRITICAL 9.8 UPGRADE Versions of the package net.sourceforge.htmlunit:htmlunit from 0 and before 3.0.0 are vulnerable to Remote Cod
- CVE-2023-49093 CRITICAL 9.8 UPGRADE HtmlUnit is a GUI-less browser for Java programs
- CVE-2023-2798 HIGH 7.5 UPGRADE Those using HtmlUnit to browse untrusted webpages may be vulnerable to Denial of service attacks (DoS)
- CVE-2022-29546 HIGH 7.5 UPGRADE HtmlUnit NekoHtml Parser before 2.61.0 suffers from a denial of service vulnerability
- CVE-2022-28366 HIGH 7.5 UPGRADE UPGRADE Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that
FAQ
How do I fix htmlunit vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is htmlunit being exploited right now?
None of the tracked htmlunit CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which htmlunit CVE should I patch first?
CVE-2023-26119 currently ranks highest (65/100): Versions of the package net.sourceforge.htmlunit:htmlunit from 0 and before 3.0.0 are vulnerable to Remote Cod.